NICKBEL FORUM

Hantek 2c42 / 2d42 / 2c72 / 2d72

nick · 25077

Zogras

  • Newbie
  • *
    • Сообщений: 7
Ответ #720 : Сентября 18, 2019, 10:07:07 am
Распиновка кнопок



Equizer

  • Newbie
  • *
    • Сообщений: 13
Ответ #721 : Сентября 19, 2019, 03:14:02 pm
Здравствуйте уважаемые форумчане!

С огромным интересом следил за этой темой и буквально вчера получил-таки свой 2С42. Однако позже обнаружил странные проблемы с моим устройством.
Даже при "заземленных" (Coupling - GND) каналах, периодически проскакивают случайные импульсы, которые хорошо видны в режиме Roll. Также при "заземленных" каналах лучи приподняты выше нуля и при изменении вертикального масштаба луч не двигается, то есть при 100 мВ на клетку луч приподнят на 52 мВ, при 1 В на клетку луч приподнят на 520 мВ и так далее...

Прошивки контроллера и FPGA поставил последние с сайта Hantek, ничего не поменялось.

Вопрос - в какую сторону смотреть? Помеха это или глюк в программе. Заранее благодарен за любую помощь.



netlend

  • Newbie
  • *
    • Сообщений: 19
Ответ #722 : Сентября 19, 2019, 04:22:32 pm
Прелести калибровки.....



netlend

  • Newbie
  • *
    • Сообщений: 19
Ответ #723 : Сентября 19, 2019, 07:49:04 pm
Я добился пока таких результатов,-первая фотка до калибровки ,вторая после.Как видно все немного лучше.А было почти как у Вас.



netlend

  • Newbie
  • *
    • Сообщений: 19
Ответ #724 : Сентября 19, 2019, 07:50:38 pm
Номер 2
« Последнее редактирование: Сентября 19, 2019, 08:52:34 pm от netlend »



Equizer

  • Newbie
  • *
    • Сообщений: 13
Ответ #725 : Сентября 19, 2019, 08:07:00 pm
Заметил, что приподнятие лучей является сильно заметным только в режиме Roll и при настройке Coupling-GND, при выборе AC или DC луч падает обратно ближе к нулю. Было бы интересно, если бы кто-нибудь ещё из обладателей этого осциллографа выложил свои результаты в режиме Roll и проверил наличие/отсутствие случайных импульсов.



Equizer

  • Newbie
  • *
    • Сообщений: 13
Ответ #726 : Сентября 19, 2019, 08:11:38 pm
Я добился пока таких результатов,-первая фотка до калибровки ,вторая после.Как видно все немного лучше.А было почти как у Вас.

Не совсем разобрался как вы проводили калибровку. Не могли бы вы описать это подробнее?



netlend

  • Newbie
  • *
    • Сообщений: 19
Ответ #727 : Сентября 19, 2019, 08:49:31 pm
Для начала -разобрал осциллограф.Первым делом ,поменял входные ОУ.И пошло-поехало.Апаратная чаcть -все таки требует допила.
В Вашем ослике в рабочем режиме лучи на одной линии с курсорами каналов?
А насчет мусара на экране-поищите выше ,Я вылаживал фото с своего.Есть на что посмотреть.
« Последнее редактирование: Сентября 19, 2019, 08:56:30 pm от netlend »



Equizer

  • Newbie
  • *
    • Сообщений: 13
Ответ #728 : Сентября 19, 2019, 09:09:29 pm
Для начала -разобрал осциллограф.Первым делом ,поменял входные ОУ.И пошло-поехало.Апаратная чаcть -все таки требует допила.
В Вашем ослике в рабочем режиме лучи на одной линии с курсорами каналов?

Первый канал чуть приподнят, второй на нуле.
Входные ОУ тоже планирую менять, так что любая информация по калибровке для меня актуальна.



netlend

  • Newbie
  • *
    • Сообщений: 19
Ответ #729 : Сентября 19, 2019, 09:54:07 pm
В моем приборе -при подключении зарядки(а также разряде батареи) ,во время работы-смещались лучи.На это влияет стабильность -5,0v(в моем случае пока -3,5v).Второе-питание АЦП привести к +3,0v(даташит рекомендует как оптимальное-проверенно).Когда с востока доедут необходимые компоненты-буду допиливать дальше(интерес еще не пропал).3,3v  думаю не стои поднимать-при разряде батареи до 3,2v понятно,что уже показания будут не стабильные.3.2v-DC(понижающий)-3.3V не получается.А так -кое-что поменял,кое-что убрал,и т.д.Уже на экран смотрю без чувства сожеления о покупке.....



Equizer

  • Newbie
  • *
    • Сообщений: 13
Ответ #730 : Сентября 20, 2019, 02:28:57 am
Даже при "заземленных" (Coupling - GND) каналах, периодически проскакивают случайные импульсы, которые хорошо видны в режиме Roll.

Проблему с проскакивающими из ниоткуда импульсами и неадекватной реакцией триггера на них решил откатом прошивки FPGA до V02.
Значит всё-таки глюк и надо ждать обновлений.



Chettuser

  • Newbie
  • *
    • Сообщений: 8
Ответ #731 : Сентября 20, 2019, 05:49:45 am
Первым делом ,поменял входные ОУ.
А Вы какие ставили?



netlend

  • Newbie
  • *
    • Сообщений: 19
Ответ #732 : Сентября 20, 2019, 07:49:41 am
Тут в теме все есть.AD8009.



vmv7

  • Newbie
  • *
    • Сообщений: 3
Ответ #733 : Сентября 20, 2019, 08:25:41 am
Здравствуйте уважаемые форумчане!

С огромным интересом следил за этой темой и буквально вчера получил-таки свой 2С42. Однако позже обнаружил странные проблемы с моим устройством.
Даже при "заземленных" (Coupling - GND) каналах, периодически проскакивают случайные импульсы, которые хорошо видны в режиме Roll. Также при "заземленных" каналах лучи приподняты выше нуля и при изменении вертикального масштаба луч не двигается, то есть при 100 мВ на клетку луч приподнят на 52 мВ, при 1 В на клетку луч приподнят на 520 мВ и так далее...

Прошивки контроллера и FPGA поставил последние с сайта Hantek, ничего не поменялось.

Вопрос - в какую сторону смотреть? Помеха это или глюк в программе. Заранее благодарен за любую помощь.

у меня проскакивающих импульсов нет, но земля в режиме roll приподнята на 40 mV
прошивка не менялась soft от 2019041501
FPGA V04



Chettuser

  • Newbie
  • *
    • Сообщений: 8
Ответ #734 : Сентября 20, 2019, 10:16:54 am
Тут в теме все есть.AD8009.
кто то ставил EL5166, правда там не понятно было, повлияло это как то или нет.
Ещё вопросик: кто ставил AD9218 - шумов стало меньше? Я в 48 страницах что то не нашёл результатов замены, может пропустил.
Спасибо.
« Последнее редактирование: Сентября 20, 2019, 12:39:42 pm от Chettuser »