NICKBEL FORUM

Hantek 2c42 / 2d42 / 2c72 / 2d72

nick · 208366

viazelenko

  • Newbie
  • *
    • Сообщений: 1
  • Дед
Ответ #1950 : Ноября 14, 2020, 10:38:55 pm
Добрый вечер форумчане. Принимайте в своё сообщество еще одного пенсионера. 11.112020 заказал 2d42 на али, а потом попал на этот форум. Большое спасибо вам ребята за огромный труд. Много узнал полезного для себя. Брал для автодиагностики. В машинах надо смотреть датчики, CAN, Lin шины и прочее. Не всегда оправдано разворачивать мотортестер по пустякам. Брать версию АВТО нет смысла, а перепрошить 2d42 попробую. О подводных камнях  в этом деле понял из ваших публикаций. STM программировать (прошивать) не приходилось, но понятие имею. Доставка будет наверно после нового года. Буду делиться своими работами на форуме. Применение осцилла в диагностике авто интересует наверно многих. До скорой встречи. Удачи всем и не болеть.



musor

  • Newbie
  • *
    • Сообщений: 7
Ответ #1951 : Ноября 16, 2020, 11:45:28 pm
   Продолжение истории по модернизации 2d42.
 Установил на оба канала операционники EL5166. На входе АЦП установил RC фильтр для снижения помех и ограничения полосы пропускания до 70 МГц. АЧХ, осциллограмы  и схемы прилагаются.  При замене HEF4052 на  74HC4052D установка RC фильтра обязательна (мультиплексор 74HC4052D имеет низкое сопротивление канала). 
 Проведён ряд мероприятий по калибровке каналов АЦП и снижению шумности. Проблему шумов на наносекудных диапазонах развёртки удалось решить процентов на 70. Скажу сразу, что АЦП я заменил AD9288BST-100, но простая замена АЦП практически ничего не дала. Ниже описаны выявленные проблемы и их решение.

 1. Основным источником шумов является сам АЦП. При 500нс/дел он работает на 100 МГц, при 200нс/дел и меньше - на 125 МГц. Шумы разогнанного АЦП резко возрастают. Проявляется значительным повышением шума при определённых положениях луча на экране. Повышением напряжения питания АЦП до 3.11 В удалось добиться заметного снижения шума.
  1.2. Помехи также возникают при изменении кода на выходах АЦП. Чем больше разрядов меняется тем сильнее помеха. Для уменьшения этого вида помех поменял резисторныи сборки 270 Ом на 470 Ом. Ёмкость входов ПЛИС с емкостью монтажа 7.5 пФ, времени 4нс достаточно для установления кода с АЦП. Влияние на уровень шума незначительное.
  В общем, с шумом АЦП кому как повезёт, сильно зависит от конкретного экземпляра. Но основной "шум" возникает от не вполне корретной программной калибровки.
Абсолютно верное замечание, как сам не раз натыкался в других приборах, часто шум возникает из-за несогласованности уровней связи между процом и ацп. Т.к. вся разница напряжения сигналов управления и питания ацп, приводит к сбросу излишков в питание ацп. Чем быстрее опрос - тем больше набрасывает. Бывали случаи, когда ацп с отрезанным питанием, продолжало работать, за счёт непрерывной связи, накапливая потенциал на входной ёмкости по питанию. Увеличение резисторов в разрыве цепи - несколько грубое решение, но немного помочь может. Как вариант, на шину связи можно сделать делитель, или полноценное согласование уровней микросхемой.



nvk

  • Newbie
  • *
    • Сообщений: 23
Ответ #1952 : Ноября 19, 2020, 06:55:48 pm
Хочу предупредить еще раз по поводу модернизации своих устройств - подумайте, а нужно ли оно вам...Как говорится лучшее - враг хорошего.
Итак, был куплен Hantek 2С42. DAC904E, LMH6702MA и прочая обвязка исправлена и добавлена согласно рекомендациям. Генератор заработал. Решил бороться с шумами. Попытки добавить конденсаторов впо +5В и возле АКБ приводили к невключению аппарата, вернул как было. Затем решил сделать вот такой мод
- 2 конденсатора по 20пФ на входе DAC904 -результат не удовлетворил. Снял конденсаторы и после этого обнаружил, что при подаче любого сигнала с генератора кроме меандра амплитудой больше 0,6 вольта сигналы искажаются.



vmv7

  • Jr. Member
  • **
    • Сообщений: 60
Ответ #1953 : Ноября 19, 2020, 07:13:04 pm
Хочу предупредить еще раз по поводу модернизации своих устройств - подумайте, а нужно ли оно вам...Как говорится лучшее - враг хорошего.
Итак, был куплен Hantek 2С42. DAC904E, LMH6702MA и прочая обвязка исправлена и добавлена согласно рекомендациям. Генератор заработал. Решил бороться с шумами.

а версия fpga какая?



nvk

  • Newbie
  • *
    • Сообщений: 23
Ответ #1954 : Ноября 19, 2020, 07:18:12 pm
В итоге выяснил, что на 1, 4,5 и тд ногах меандр 1.43 v, а на 2 и 3 ноге, там где 1,33v сигнал искажается. Думал, что проблема в DAC904 - заменил, проблема осталась. Куда дальше копать незнаю. Прошу помощи у знатоков... Перепрошивал, была FPGA 04, сейчас 07, прошивка последняя.



tol475

  • Newbie
  • *
    • Сообщений: 48
Ответ #1955 : Ноября 19, 2020, 08:52:33 pm
В итоге выяснил, что на 1, 4,5 и тд ногах меандр 1.43 v, а на 2 и 3 ноге, там где 1,33v сигнал искажается. Думал, что проблема в DAC904 - заменил, проблема осталась. Куда дальше копать незнаю. Прошу помощи у знатоков... Перепрошивал, была FPGA 04, сейчас 07, прошивка последняя.
Может LATTICE подбили установкой конденсаторов на входе DAC?



nvk

  • Newbie
  • *
    • Сообщений: 23
Ответ #1956 : Ноября 19, 2020, 09:45:46 pm
Может быть... сам об этом думал. Как осциллограф работает нормально, пробовал подавать со звуковой карты 1 вольт 50 Гц-20 кГц - таких искажений нет. Уже точно не помню, но в какой-то момент забыл отключить щупы от осцила и запустил калибровку... Могло ли это повлиять?



nick

  • Administrator
  • Sr. Member
  • *****
    • Сообщений: 346
Ответ #1957 : Ноября 19, 2020, 09:49:52 pm
Может быть... сам об этом думал. Как осциллограф работает нормально, пробовал подавать со звуковой карты 1 вольт 50 Гц-20 кГц - таких искажений нет. Уже точно не помню, но в какой-то момент забыл отключить щупы от осцила и запустил калибровку... Могло ли это повлиять?

может проблема в том что DAC904 - это 14-битный ЦАП?

надо ставить DAC902 - максимум.. (наверное)
так как 2 последний ноги 13-14 биты даже не растрассированы



vmv7

  • Jr. Member
  • **
    • Сообщений: 60
Ответ #1958 : Ноября 19, 2020, 09:50:43 pm
Может быть... сам об этом думал. Как осциллограф работает нормально, пробовал подавать со звуковой карты 1 вольт 50 Гц-20 кГц - таких искажений нет. Уже точно не помню, но в какой-то момент забыл отключить щупы от осцила и запустил калибровку... Могло ли это повлиять?
а если вернуть всё взад, тестовый меандр остался?



vmv7

  • Jr. Member
  • **
    • Сообщений: 60
Ответ #1959 : Ноября 19, 2020, 09:51:50 pm
Может быть... сам об этом думал. Как осциллограф работает нормально, пробовал подавать со звуковой карты 1 вольт 50 Гц-20 кГц - таких искажений нет. Уже точно не помню, но в какой-то момент забыл отключить щупы от осцила и запустил калибровку... Могло ли это повлиять?

может проблема в том что DAC904 - это 14-битный ЦАП?

надо ставить DAC902 - максимум.. (наверное)
так как 2 последний ноги 13-14 биты даже не растрассированы
904 работает, проверено.



nvk

  • Newbie
  • *
    • Сообщений: 23
Ответ #1960 : Ноября 19, 2020, 09:55:25 pm
Ничего возвращать не нужно, замерил на месте снятой перемычки - тестовый меандр есть. DAC904E поставил сразу и все работало... И сейчас до 0,6в все более менее, не идеал конечно, и 1 МГц и 10, и 20...



nick

  • Administrator
  • Sr. Member
  • *****
    • Сообщений: 346
Ответ #1961 : Ноября 19, 2020, 09:56:35 pm
Может быть... сам об этом думал. Как осциллограф работает нормально, пробовал подавать со звуковой карты 1 вольт 50 Гц-20 кГц - таких искажений нет. Уже точно не помню, но в какой-то момент забыл отключить щупы от осцила и запустил калибровку... Могло ли это повлиять?

может проблема в том что DAC904 - это 14-битный ЦАП?

надо ставить DAC902 - максимум.. (наверное)
так как 2 последний ноги 13-14 биты даже не растрассированы
904 работает, проверено.

ну теоретически должен

а фото реально там? фото реального расположения компонентов в студию в разрешении




nvk

  • Newbie
  • *
    • Сообщений: 23
Ответ #1962 : Ноября 19, 2020, 10:11:46 pm
Вот фото, заменил резистор R61 2 кОм на 1,8 кОм - ничего не изменилось.



nick

  • Administrator
  • Sr. Member
  • *****
    • Сообщений: 346
Ответ #1963 : Ноября 19, 2020, 10:13:19 pm
Может быть... сам об этом думал. Как осциллограф работает нормально, пробовал подавать со звуковой карты 1 вольт 50 Гц-20 кГц - таких искажений нет. Уже точно не помню, но в какой-то момент забыл отключить щупы от осцила и запустил калибровку... Могло ли это повлиять?

может проблема в том что DAC904 - это 14-битный ЦАП?

надо ставить DAC902 - максимум.. (наверное)
так как 2 последний ноги 13-14 биты даже не растрассированы
904 работает, проверено.

ну теоретически должен

а фото реально там? фото реального расположения компонентов в студию в разрешении
какое ещё фото? уже несколько человек ставили его, всё работало. И я тоже ставил, всё работало, но не понравилось, синусоида на высоких частотах больше плясала.


да не! я не про то

а о проблеме nvk - его фото, прибора который криво работает




vmv7

  • Jr. Member
  • **
    • Сообщений: 60
Ответ #1964 : Ноября 19, 2020, 10:15:22 pm
Вот фото, заменил резистор R61 2 кОм на 1,8 кОм - ничего не изменилось.
а на плисине ножки замкнуты?
« Последнее редактирование: Ноября 19, 2020, 10:18:24 pm от vmv7 »